OS

macOS Monterey support is bad news for older MacBook Pro and Air models

Apple just revealed the latest version of macOS at WWDC, and also listed the Macs which will support Monterey – so for those wondering if they might be left out in the cold with macOS 12, here’s the full lowdown on whether or not you can grab it.

The list of compatible Macs as detailed by Apple is as follows:

  • 12-inch MacBook (early 2016 and later)
  • MacBook Air (early 2015 and later)
  • MacBook Pro (early 2015 and later)
  • Mac mini (late 2014 and later)
  • iMac (late 2015 and later)
  • iMac Pro (2017 and later)
  • Mac Pro (late 2013 and later)

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button